latest and greatest, progress mail 5 (stable 2.6.28 usage)

Franky Van Liedekerke liedekef at
Sat Apr 11 00:44:22 CEST 2009

On Sat, 11 Apr 2009 00:32:26 +0200
Petr Vanek <vanous at> wrote:

> >see my mail and my install script ... bluez4 doesn't work with
> >qtextended (not for me anyway), so in my script I downgrade to
> >bluez3, and fix the poweron script at the same time. But again, see
> >my mail:
> >
> >"
> >- bluetooth is not working totally ok, only after initial boot it
> >  works, not after suspend/resume. Seems to be kernel/bluez3 version
> >  combo issue ...
> >"
> hey Franky, nice piece of work you did, thank you.
> well, i did use the complete procedure you described. the scripts are
> there too... plus, i tried before suspend... still no luck
> i have the kernel from your site
> thank you
> petr

Hi Petr,

you get the error because in the powerup script there's this line:

echo 3300
> /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/voltage_ldo4

and on a 2.6.28 or newer kernel, this path doesn't seem to be present
(and I don't know the new path). This can be ignored.
But before suspend, you don't need to use the poweron script (in fact
you probably shouldn't use it before suspend). Just go to the bluetooth
settings and give it a go. It might be that the bluetooth reset way in
the poweron script is in fact part of the problem ...
I've changed the poweron script on my site to just call
"/etc/init.d/bluetooth start" now.


More information about the community mailing list