[SHR] GPRS, again

kimaidou kimaidou at gmail.com
Tue Apr 14 15:01:29 CEST 2009

Have you tried to update the module with ppp-generic :

echo ppp-generic > /etc/modutils/ppp-generic
shutdown -r now

This works great for me.
For debuggin and connecting via terminal, I use :

mdbus -s org.freesmartphone.ogsmd /org/freesmartphone/GSM/Device
org.freesmartphone.GSM.PDP.ActivateContext mygprs x x

Replace mygprs with your provider adress. You must leave the double x at the
end : they are here for "no user and password needed"


2009/4/14 Pander <pander at users.sourceforge.net>

> Hi all,
> Still I cannot get GPRS working on unstable, although I have gotten an
> subscription with GRPS about 4 months ago, hoping I could use it with SHR.
> I tried the settings menu but that did not work. Even manually editting
> shr_grps.py to the correct APN, login and password did not help.
> Manually, I have also tried:
>  mdbus -s org.freesmartphone.ogpsd /org/freesmartphone/GSM/Device
> org.freesmartphone.GSM.PDP.ActivateContext internet
> (my provider has internet as APN and empty string as login and passwd)
> The result is:
>  /org/freesmartphone/GSM/Device: ActivateContext failed:
> org.freedesktop.DBus.Error.UnknownMethod
> What is THE way to get GRPS working on SHR?
> Thanks,
> Pander
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20090414/665fc31a/attachment.htm 

More information about the community mailing list