[QtExtended] Latest and greatest, progress mail 7

Franky Van Liedekerke liedekef at telenet.be
Wed Apr 15 20:45:39 CEST 2009

(install instructions and script updated on 2090415: see below)

Problems solved:
- 20090401: 2.6.28 ok (even 2.6.29-rc2 ok)
- 20090401: alarms OK (using atd from
  http://www.angstrom-distribution.org/unstable/armv4t/base/, since no
  newer package exists), normal + when suspended
- 20090401: wake up when receiving sms, OK
- 20090401: call + echo check, all OK
- 20090401: duplicate sms thing: solved (see also fix on 20090412)
- 20090401: mail ok
- 20090401: wifi ok
- 20090403: voice notes (see my mail/patch) ok
- 20090404: usb cable handling: ok (mailed a patch to Filip, I hope he
  integrates all the 2.6.28 patches and commits them)
- 20090404: bluetooth ok (need to downgrade to bluez3 and not use
  bluez4, install script updated accordingly)
- 20090410: voicemail number is now saved across reboots (see
- 20090410: snooze function works correctly now for repetitive alarms
  (see http://trac.karadog.net/qt-extended-improved/ticket/27)
- 20090412: wlan no longer always "online" after unsuspend. I don't
  know if this saves power or not though ...
- 20090412: SMS's are deleted from SIM after being read (see
http://trac.karadog.net/qt-extended-improved/ticket/29). THIS NEEDS

- 20090413: vibrating/alarm/snoozing: works reliable now (there was a
  bug in the used timers logic that could cause infinite vibrating)
- 20090415: "missed calls bug finally solved, it took some code
  rewriting I found in the qtopia version Om2008.12 (thanks Holger!)
- 20090415: outgoing call doesn't register anymore as "missed" when
  aborting the call before the connection is made (again: thanks

(the last 2 fixes aren't in any tickets, I need to create a patch for

Problems found (more like small nuisances now):
- if you set the time back to something in the past, the clock service
  crashes and you need to restart qtextended if you want to use the
  clock again
- bluetooth is not working totally ok, only after initial boot it
  works, not after suspend/resume. Seems to be kernel/bluez3 version
  combo issue ... After suspend/resume bluetooth seems to work, but
  receiving files for sure don't.
- if you try to delete the "Wireless Lan", the system crashes ... cool
  huh, a crashed phone? So for now: don't do it :-)

- waiting call notification doesn' t work for me, it seems that the
  command to set the CCWA on the network fails for me:

 AtChat :  T : "AT+CCWA=1,1,1"
 AtChat :  F : "+CME ERROR: 4"
 AtChat :  T : "AT+CCWA=1,2"
 AtChat :  F : "+CCWA: 0,7"
 AtChat :  F : "OK"

The error "+CME ERROR: 4" means that the operation is not supported. Is
this provider related?

- I had a problem with the battery service crashing on me; all of the
  suddenly (after many suspend/resumes) the device gave me a warning
  that the battery was critical low, but after another suspend/resume 
  cycle, the icon showed a full battery (even though the battery was at
  60% or so)

Install instructions:
download the script
http://users.telenet.be/liedekef/openmoko_install.sh , read the comments
at the top and then execute the script on your openmoko (after having
flashed the device and made sure internet works).
For those who just want to replace their existing QtE: just download
the QtE compressed file and replace your existing QtE with it:



More information about the community mailing list