Asterisk on Freerunner was: voip on Debian

Nicola Mfb nicola.mfb at
Sun Apr 19 16:20:24 CEST 2009

2009/4/19 Al Johnson <openmoko at>:
>> Let's survive this interesting topic.
>> I will be happy to write an AMI gui but now I'm hold having problems
>> with the alsa channel. Using the pcm default is not compatible with
>> the default shipped /etc/asound.conf, so I just tried to use
>> plughw:dnsoop and plughw:dmix, the result is that there freerunner
>> does not ring on incoming call (and you cannot hear the other peer),
>> while audio transmitting is perfect.
> I'm guessing 'does not ring' means it uses the earpiece for ringing instead of
> the speaker. You will need stereoout.state for the ringing, then change to
> voip-handset.state when answering the call. This is what is needed when
> working with linphone, although the change of state is not automated yet.
> voip-handset.state is in both FSO and SHR IIRC. You should be able to do the
> state switch with an asterisk script.

As AMI emits all needed events I'll add fso support for the GUI to
handle the switching automatically, while for a true voip fso
integration I think that's has to be discussed as actually on incoming
GSM call fso will automatically switch to stereoout and gsm alsa state
and may create problems during a voip session.
But we may superseed on this actually until having a well working
asterisk on freerunner, and I'll complete the AMI gui.
However if I use plughw:0,0 in asterisk alsa.conf I may hear the ring
in the earpiece (the only problem was that I had to change the speaker
alsa control from 0 to max in voip state).
I have stuttered outgoing audio, so I think the problem is with alsa
buffer/periods etc., the proposed asound.conf file should work as
create longer buffer/periods both for input and output, but using it
asterisk does not speak anymore to the erapiece. I enabled the logging
to maximum details and I may see effectively "Alsa/default is ringing"
but no sound is emitted, and I do not know why, as in this situation
aplay works fine.
> For linphone I use Brian Code's asound.conf :
> This uses dmix and dsnoop and gives stutter-free sound in both directions with
> linphone. It does have echo since we can't use the suppression in the GSM
> chipset.

Asterisk should be able to do echo suppression?
Is this present with external headphones too?



More information about the community mailing list