backing up rootfs fails - after 40m FreeRunner continues booting

Cameron Frazier frazier.cameron at
Mon Apr 20 21:39:03 CEST 2009

On Mon, Apr 20, 2009 at 2:51 PM, Bram Mertens <mertensb.mazda at> wrote:
> On Mon, Apr 20, 2009 at 8:12 PM, Cameron Frazier
> <frazier.cameron at> wrote:
>> On Mon, Apr 20, 2009 at 2:03 PM, Bram Mertens <mertensb.mazda at> wrote:
>> <snip>
>> Have you tried using NeoTool [1]?  It's always worked quite well for
>> me, and the backing up process avoids dfu-util.
>> [1]
> I have tried to use it before when I initially went to pick up the
> device but never succeeded, probably because we were using the wrong
> files.
> And the instructions seemed clear enough to use the command line utility.
> The current problems/questions would have arisen with NeoTool anyway,
> looks like I made a mistake when rebooting the device.
> So when you have flashed the U-Boot with NeoTool, how do you proceed?
> Unplug it first, power down, then boot again or use the boot menu to
> reboot?  And did you boot the device normally or immediately into NOR
> or NAND?
> The display still shows the openmoko logo, guess I'll have to hard
> reset it though I hope that won't break anything...

I've always just:

- flashed
- powered down, which the FR seems to do on it's own once u-boot times out
- unplug the usb, as I've found that leaving it in will cause hangs
similar to what your seeing
  (oddly I don't have this issue with the AC adapter)
- turn on pre normal procedure (power button for 8-10 sec)

I use NeoTool most times since I like the backup method (having had
numerous problems with dfu-util backups) and it helps to ensure I'm
not throwing improper commands when I flash.  I have little faith in
the user on my end.

Hope that helps.


More information about the community mailing list