backing up rootfs fails - after 40m FreeRunner continues booting

Dale Maggee antisol at
Tue Apr 21 10:36:20 CEST 2009

Hash: SHA1


To backup your rootfs with NeoTool:

* Make sure you have a working image on your Neo. By 'Working', I mean
it should boot into the GUI, and networking should work - you should be
able to ssh into your neo. NeoTool is supposed to be pretty much "idiot
proof", so it should tell you if this isn't the case.

* Boot your Neo all the way into the gui. (NeoTool's rootfs backup needs
to use SSH, so your Neo should be completely booted, not at the boot menu)

* Run NeoTool, choose backup, select 'Root Filesystem' when it prompts
for what to backup, and choose 'Go!'.

* you may be told that you don't have mkfs-jffs2 installed. If this
happens, ssh into your neo and "opkg install mkfs-jffs2"

* the backup will take a while (maybe 20-30mins?). If you chose the
default backup method (jffs2), the file it produces will be flashable
using dfu-util or NeoTool.

- -Dale

Bram Mertens wrote:
> On Mon, Apr 20, 2009 at 9:39 PM, Cameron Frazier
> <frazier.cameron at> wrote:
>> On Mon, Apr 20, 2009 at 2:51 PM, Bram Mertens <mertensb.mazda at> wrote:
>>> On Mon, Apr 20, 2009 at 8:12 PM, Cameron Frazier
>>> <frazier.cameron at> wrote:
>>>> On Mon, Apr 20, 2009 at 2:03 PM, Bram Mertens <mertensb.mazda at> wrote:
>>>> <snip>
>>>> Have you tried using NeoTool [1]?  It's always worked quite well for
>>>> me, and the backing up process avoids dfu-util.
>>>> [1]
>>> I have tried to use it before when I initially went to pick up the
>>> device but never succeeded, probably because we were using the wrong
>>> files.
>>> And the instructions seemed clear enough to use the command line utility.
>>> The current problems/questions would have arisen with NeoTool anyway,
>>> looks like I made a mistake when rebooting the device.
>>> So when you have flashed the U-Boot with NeoTool, how do you proceed?
>>> Unplug it first, power down, then boot again or use the boot menu to
>>> reboot?  And did you boot the device normally or immediately into NOR
>>> or NAND?
>>> The display still shows the openmoko logo, guess I'll have to hard
>>> reset it though I hope that won't break anything...
>> I've always just:
>> - flashed
>> - powered down, which the FR seems to do on it's own once u-boot times out
>> - unplug the usb, as I've found that leaving it in will cause hangs
>> similar to what your seeing
>>  (oddly I don't have this issue with the AC adapter)
>> - turn on pre normal procedure (power button for 8-10 sec)
>> I use NeoTool most times since I like the backup method (having had
>> numerous problems with dfu-util backups) and it helps to ensure I'm
>> not throwing improper commands when I flash.  I have little faith in
>> the user on my end.
> Thanks,
> I pulled the battery and booted into NOR, it still shows:
> U-Boot 1.3.2-moko12 (May 09 2008 - 10:28:48)
> select reboot from menu - FDOM boots.
> Shut down device to NAND boot menu.
> NAND boot menu shows: pr 19 2009 -
> 19:10:05)520a22715fe7ff069b36b7dfdbb925a8e5a (A
> So it looks like NAND U-Boot was updated but NOR hasn't.  However
> specifically states that you need to be in NOR U-Boot before
> flashing/backing up.
> After reading I get the
> impression that flashing NOR is not really recommended compared to
> flashing NAND.
> I'll try with NeoTool since even with the new U-Boot a backup fails
> after 38minutes (while booted to NAND).
> Regards
> Bram
> _______________________________________________
> Openmoko community mailing list
> community at

Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the community mailing list