Freerunner, strange issues with kernels >= 2.6.28; some boot, some don't

E. Boer at
Wed Apr 22 20:27:59 CEST 2009


I'm still struggling with the newest kernels >= 2.6.28. I tried SHR [1],
OM2009 (latest)[2] and Android [3]. All have a kernel >= 2.6.28. But
only the kernel of Android works! So I downloaded the latest
Andy-tracking-more-drivers kernel [4] and flashed it to the freerunner
and it works, but the wireless network of this kernel doens't work.
Tried the andy-tracking-more-drivers-stable but this kernel also doesn't
work :-(. Moving to the experimental kernels [5] doesn't work too

Even boot from SD doesn't work :-( ............ I think I forgot
something, but what ................ When I start the Freerunner, the
system says (with experimental kernel [5]) :

NAND read: device 0 offset 0x80000, size 0x200000
 2097152 bytes read: OK
## Booting kernel from Legacy Image at 32000000 ...
   Image Name: openmoko/2.6.28-andy-tracking+gi
   Created:    2009-04-21 19:41:02 UTC
   Image Type: ARM Linux Kernel Image (uncompressed)
   Data Size:  1831744 Bytes = 1.7 MB
   Load Address: 30008000
   Entry Point:  30008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ..." 

that's it. I've tried u-boot and qi, but the results are the same.

In short:
Only the standard kernel from Android and the
uImage-moredrivers-GTA02_andy-tracking-d1a9cf85c8608601.bin are working.
Other kernels don't.

Maybe there is something with my u-boot / qi environment? Can I clean up
that with dfu-util?

Hopefully somebody can point me in the right direction.




More information about the community mailing list