USB Kernel problem with latest SHR unstable

Robin Paulson robin.paulson at
Sat Apr 25 10:37:50 CEST 2009

2009/4/25 Robin Paulson <robin.paulson at>:
> 2009/4/24 Denis Johnson <denis.johnson at>:
>> Flashing the latest SHR image and kernel from
>> 23 April
>> uImage-2.6.29-oe10+gitr119800+0b9d21bf5d05d5dd909425a67a8be2eb1c1fc579-r3.4-om-gta02.bin
>> I could not connect via SSH over USB from my Ubuntu 8.10 host. lsusb
>> on the host could see the neo but could not ifup usb0
>> Only after reflashing just the kernel back to Apr 9, could I again
>> reconnect via SSH. I have not tried kernels posted between those dates
>> to work out where the problem starts.
>> Howver to confirm it, I have reflashed back to the latest 23rd April
>> but could not connect, then reflashed back to 9th April and worked
>> again.

well, i fixed it - i can now ssh into my freerunner.

i'm not entirely sure what it was, but i think it was related to some
fiddling i did with depmod and modprobe on the phone. i'm guessing
some usb modules weren't loaded by default

More information about the community mailing list