USB Kernel problem with latest SHR unstable

Franky Van Liedekerke liedekef at
Sat Apr 25 22:05:35 CEST 2009

On Sat, 25 Apr 2009 20:37:50 +1200
Robin Paulson <robin.paulson at> wrote:

> 2009/4/25 Robin Paulson <robin.paulson at>:
> > 2009/4/24 Denis Johnson <denis.johnson at>:
> >> Flashing the latest SHR image and kernel from
> >> 23 April
> >>
> >> uImage-2.6.29-oe10+gitr119800+0b9d21bf5d05d5dd909425a67a8be2eb1c1fc579-r3.4-om-gta02.bin
> >>
> >> I could not connect via SSH over USB from my Ubuntu 8.10 host.
> >> lsusb on the host could see the neo but could not ifup usb0
> >>
> >> Only after reflashing just the kernel back to Apr 9, could I again
> >> reconnect via SSH. I have not tried kernels posted between those
> >> dates to work out where the problem starts.
> >>
> >> Howver to confirm it, I have reflashed back to the latest 23rd
> >> April but could not connect, then reflashed back to 9th April and
> >> worked again.
> well, i fixed it - i can now ssh into my freerunner.
> i'm not entirely sure what it was, but i think it was related to some
> fiddling i did with depmod and modprobe on the phone. i'm guessing
> some usb modules weren't loaded by default

ok, but how did you get to fiddle on the phone? Do you mean you
actually used a terminal app, did some kind of modprobe on the phone
and it started working? And now you don't remember what it was ... does
this mean after the next reboot, you don't have ssh access anymore?
Do the SHR people test these images? I've been told every time again
it's the host (ethX instead of usb0), but I seriously believe something
is wrong with the generated images ... my host fedora 10 system doesn't
give any output in /var/log/messages when I plug in the phone with
newer images (any "old" image reacts just fine), while it does give me
info when I boot the phone in the NOR menu to flash it.
To prove it myself, I will *again* flash my phone with the latest
image/kernel found in


More information about the community mailing list