[SHR-Testing] Wireless Frustration (was: Re: [SHR-Testing] /etc/network/interfaces edit question)

Nicola Mfb nicola.mfb at gmail.com
Wed Apr 29 04:45:33 CEST 2009

2009/4/27 Adam Jimerson <vendion at gmail.com>:
> I am still trying to get my wireless to work on the 4/16 release of
> SHR-Testing, I can get a scan to work on eth0 every now and then and the
> rest of the time I get a "device does not support scanning error".  No
> matter if I can scan or not eth0 will not connect to any AP.  I have set up
> the /etc/network/interfaces so that eth0 uses wpa_supplicant, which I have
> the file setup with the APs and everything, and when I try and ifup eth0 it
> goes though the configurations but stops at a "No lease failing" error.  I
> have been at this for a while trying to get it to work and all my attempts
> have failed.  If anyone has any kind of suggestion, or if they have had this
> problem with this version of SHR-Testing please reply, I getting desperate
> and will try anything to get it to work.

I solved at least the no lease problem hacking a bit
/etc/udev/scripts/network.sh, basically when eth0 is added it launches
wpa_supplicant with -W (wait for wpa_cli) instead of ifup, after
launches wpa_cli -a /etc/wpa_supplicant/wpa_cli.sh, the last is a
script called when some event happens (CONNECT/DISCONNECT), on CONNECT
it launches udhcpc, and as eth0 is already associated and
authenticated I finally get a lease. I think this may be obtained
using wpa-roam too in a more elegant way, but it failed and I'm a bit
lazy to read an incomplete file set.
An issue is that power cycling the AP resulted in kernel reporting
ar6000 disconnected/connected but wpa_cli was not notified, after that
the freerunner continued to stay connected but I do not know if moving
to another configured network will notify a new association and a new
IP or I have to disable/reenable wifi.
This works starting/stopping wifi from shr-settings too without the
need of launch mofi.
I toggled wifi several times and it worked on a wpa-psk network
without problems, so I *suppose* that udhcpc when launched with the
eth0 not associated creates problems.
Tomorrow I'll try with the wpa2-enterprise network and report.


More information about the community mailing list