[QtMoko] new images v6 - problems over problems.

Tschaka Stuff4tschaka at gmx.net
Thu Aug 6 00:31:23 CEST 2009

Radek Polak wrote:
> Hi,
> i have just uploaded new QtMoko debian images. You can download as
> usually from
> http://activationrecord.net/radekp/qtmoko/download/
> MD5 sums:
> 55cae339a3bbd714cc98f8d057b82014  qtmoko-debian-v6.jffs2
> d49dcd64f34e0675874a4bd4f73af79c  qtmoko-debian-v6.tar.gz
> f64f5ff2e7dad0202e7cb69d263d006d  uImage-v6.bin
> Changes from previous version:
> * wifi should work
> * alarm should work (only first alarm after boot, second probably wont
> ring)
> * greatly improved boot speed (can be even more sped up if you replace
> bash with dash)
> * fixed blinking cursor after app in QX ended up
> * SSH and other services are starting after Qtopia is up (so you have to
> wait some time before you can ssh to neo)
> I hope that no regression crept in and i'd recommend this version.
> There are still problems with long SMS and contacts import. It will take
> some time because my holidays end up today and i will be probably busy
> for some time.
> Anyway, enjoy images
> Regards
> Radek
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community


QTMoko doesnt seem to make it for me. although it feels like a phone, it is
totally unreliable. it's totally freezing occassionally, which led me twice
to a broken file system, which the fsck at startup didnt fix (it wanted to
reboot after fsck, but then i got a nice kernel panic). Luckily i'm still
having SHR on my phone, to run a file system check over the partition of
Qtmoko. This worked flawlessly once, once after i rebooted then, all my
settings were gone. the messages application wouldnt startup anymore, the
clock was shown all the time. i then accidently clicked on "Games" in the
menu, which led the phone to lock up again. 

Once the file system was that much damaged, that qtmoko left me with a nice
terminal login screen at init2. what to do if you got this in the middle of
nowhere, only coz ur phone locked up?!

this mainly happened, when i was setting up the email account via wifi.
(actually that's been the only "advanced" task i did with qtmok yet, so this
isn't essentially caused by the email programm. once this happened when i
was doing something else with various programms)
Once this happened, when the emails from imap were being received, and i
thought, ok, cool, now lets try to click "New" to compose an e-mail. Phone
crashed. Note, that i still could ping the phone.

Once this happened after i eventually received all the imap emails, and
scrolled on the top of the list. The screen started to flicker like hell
(all i saw was a turquoise screen, flickering a bit. there was NOTHING
visible from the menu i've been before). Only reboot through pressing the
power button for 8 seconds worked. (missed to do a video of this, i'll do
when it happens again.)

Things like these happened earlier these days with qtmoko, when i even had
to pull the battery to get the phone up running again. 

Note that i tried QTmoko first when v5 got released, which happened a few
days ago. i never actually got beyond the configuration phase. the phone
just crashed then. i first thought, that this may be caused by full ram (b/c
this freeze up happened in SHR as well 1 or 2 times). today i bought this 2
gb SD card, made a swap partition 270 mb large and installed qtmoko v6 on
the remaining 1,7 GB partition. So full diskspace/RAM/Swap is quite

Any hints on how to go on, or by what these problems my be caused? As much
as i like qtmoko with its polished email, messages, phonebook and
phonefeeling, that is just not acceptable for me. i'm happy that the FR
isn't my primary phone yet, so i dont have to rely on it too much at the
moment and can play around with such flaws. For now i am back to SHR

Thanks for your help.
i'm off to bed. Good night. 
View this message in context: http://n2.nabble.com/-QtMoko--new-images-v6-tp3385796p3395174.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list