Free runner doesnot power up

Rask Ingemann Lambertsen ccc94453 at
Sat Aug 8 14:24:18 CEST 2009

On Sat, Aug 08, 2009 at 11:58:16AM +0530, RANJAN wrote:
> Hi,
> I have not been using my free runner for about a week.I tried to turn it on
> by pressing the power button but it does not.I have plugged in the Charger
> and pressed the power button but still it does not turn on .I even tried NOR
> boot with Aux and power button but still it does not turn on.Is it that the
> device is dead or the battery just need to be charged for some hours before
> I can use it again?

   Please say which date code you have (printed in battery compartment) and
if you know it, which hardware revision you have. Hardware revision A5 (date
codes 20080718 and earlier?) aborts the power-on sequence at a very early
point if the battery has been completely discharged.

   Things to try if you have hardware revision A5:
1) Borrow a compatible battery. See
2) Get hold of an external Li-Ion charger. See

Rask Ingemann Lambertsen
Danish law requires addresses in e-mail to be logged and stored for a year

More information about the community mailing list