Freerunner audio channels

David Fokkema dfokkema at
Mon Aug 10 17:13:18 CEST 2009

On Mon, 2009-08-10 at 16:33 +0300, Alexander Shulgin wrote:
> On Mon, Aug 10, 2009 at 14:53, Paul Fertser<fercerpav at> wrote:
> > Alexander Shulgin <alex.shulgin at> writes:
> >>>
> >>> One of the problems is that some freerunner revisions are in fact
> >>> different in hardware. Most devices have 1uF capacitors instead of
> >>> R3004/R3005 (which should be 0R), and that's not a joke. That is
> >>> earpiece path and not surprisingly that devices that have those
> >>> capacitors have considerably lower sound volume from the earpiece.
> >>
> >> And what do I do if I happen to have one?
> >
> > Tweak alsa state files appropriately. There's a routing diagram on the
> > wiki that explains everything needed.
> I'm quite experienced programmer, but this is just too deep for me
> (plus the documentation is sparse and decentralized).
> Could anyone assist me on this task?  What exactly to change?
> Maybe someone already had similar problem and solved it?  It would be
> really nice to see the solution and try it out.

Well, if you read the first post in this thread, it tells you two

1) Yes, the documentation is too sparse and often self-contradictory
2) Use Angus Ainslie's mixer scripts (see if that doesn't
work (it doesn't currently on my phone) use instead of An older version, but very functional.

When using, first make a call, _then_ run the script and play
with the settings. In the OP, you can see what I have done. To maximize
earpiece volume, just max out the bottom two settings. In this script,
input and output are reversed (just the labels, nothing more).

Good luck!


More information about the community mailing list