[SHR-U] Impressions and Problems

Dan Staley daniel.l.staley at gmail.com
Fri Aug 14 16:42:00 CEST 2009

Now that my moko has the buzzfix, I can finally use it as a real phone, and
not just a handheld linux box.
I flashed SHR-U on my phone and can say that overall, it has worked pretty
well...however I have noticed a couple of things that I'm thinking surely
someone else has run into and maybe has a fix for.

1.)  Occasionally (usually after a phone call) it seems that GSM, suspend,
et al. stop working.  Just from looking over bug reports and such, I'm
assuming this is due to frameworkd crashing...however I haven't noticed
anything unusual in the logs...does anyone else experience this?  Is the
best fix just to restart frameworkd when it happens?

2.)  One of the first things I noticed was that when a text message arrived,
the number associated with it has the international code (1) prefixed at the
beginning.  On my sim card, I only had the numbers stored with the area code
+ 7 digits for number....no international prefix.  So using pisi (which
works perfectly btw!  Thanks for that app!)  I exported my contacts to a vcf
file and ran some regexes with vim over it to prefix a 1 to all my numbers
and went back to my messages....sure enough the numbers were associated with
names now.  However, soon after I got a phone call....and I noticed that all
phone calls had numbers reported that did NOT have the 1 prefixed...so no
names were associated with them now!
Has anyone found a fix for this?  Is there a patch for the SHR apps that
make them lookup a number that is not a direct match (missing a 1 or an area

I installed the opimd-utils package and tried these out.  It seems the
messages application included in this package can recognize a number
correctly (if it comes in with a 1 prefixed, but the listing in my phone
book does not).  If I wanted to use this messaging application instead of
the default one in SHR....how would I do that?  How do I disable the old
one?  Does anyone know if litephone handles this correctly?

-Dan Staley
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20090814/435629f3/attachment.htm 

More information about the community mailing list