dbus deb with increased timeout

arne anka openmoko at ginguppin.de
Mon Dec 14 13:11:42 CET 2009

> This is great news - but it is surprising that it needs a change to
> the dbus code.  Isn't there a way to configure the default dbus
> timeout, or to set it for particular methods?  From googling I've
> found hints that adding "timeout=100" to the relevant method call
> might work - but unfortunately nothing definitive on this.

not afaik.
a normal per call or startup option would have been my first choice, but  
 from everything i could gather, there's no way to do that.
i'd expected the patch mentioned to add exactly that kind of option, but  
it turned out to add only a build time option.

but yesterday the phone (or maybe only zhone) lost connection to the  
network which made me miss an appointment and several calls (once a year  
people call ...).
in a hurry i restarted the whole phone but zhone was showing exactly the  
same issues again :-(

back at home i set the t/o to 250*1000 and rebuild and this time i also  
installed the libdbus-package (not only dbus and dbus-x11), since i didn't  
check what package will contain the modified files.
restart frameworkd and zhone allowed immediate pin input, don't know how  
much it is worth ...

but i put the new packages up at ginguppin.de tonight.

More information about the community mailing list