building qtmoko V15

Dave at
Thu Dec 17 11:06:34 CET 2009

Hi all,

I am attempting to build qtmoko from source and have a problem. I'm not very
familiar with the qt environment and hoping someone can help.

I followed the instructions on radek's git README, downloaded toolchain,
cloned git and attempted to build. The first time I ran the configure
command, I received an error that qmake could not be found and to put
"-build-qt" in the configure flags. I did this and qt appeared to build ok.
"configure" now works.

Now when I run "make" i receive this error:

root at davetv-laptop:/build# make
make: running qbuild default
Project () ERROR: An error occured while evaluating a QBuild script
    File:    /qtmoko/ at 87
    Error:   SyntaxError: Parse error

make: *** [all] Aborted

The line that is causing the problem is - var script ="SDK_SCRIPT");

After some experimentation (by commenting out stuff) It appears that the
compiler has a problem with"xxx"). If I comment it out in
/qtmoko/ it fails elsewhere.

Any suggestions?

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list