Least-hassle method of getting a usable Web browser + telephony support while GPRS is enabled?

Brolin Empey brolin at brolin.be
Thu Dec 17 20:31:45 CET 2009

2009/12/16 Al Johnson <openmoko at mazikeen.demon.co.uk>

> On Thursday 17 December 2009, Brolin Empey wrote:
> > Hello list,
> >
> > I am using QtMoko v14.  AFAIK, QtMoko does not support GSM multiplexing,
> > which means even if I had a working and usable Web browser for QtMoko, I
> > could not use telephony functionality, such as making and receiving phone
> > calls, while GPRS is enabled.  If I wanted to have Internet access on my
> > FreeRunner, what is the least-hassle method of getting a usable Web
> browser
> > + telephony and SMS support while GPRS is enabled?  Am I better off
> finding
> > a usable proprietary phone?
> Since you've already got the phone you may as well give the other firmware
> options a try. We keep finding people have different definitions of
> 'usable'
> so you'll have to see what suits you.
> SHR should be easy to try, and is supposed to do everything you want.
> There's
> a GUI for the GPRS config. It has multiplexing so GPRS, SMS and telephony
> should work together (I say should as I haven't tried GPRS recently.)
> Midori
> might be a suitable browser, although there is a problematic interaction
> between the illume keyboard and midori's address autocompletion at the
> moment.
> I have already tried the Om2008.8 (?) which was preinstalled on my
FreeRunner, Om2009 (completely unusable because the GUI kept becoming
unresponsive), SHR-U (version 080808 or 090808?  I can find out which
version I tried when I am home tonight.  It was less unusable than Om2009
but still unusable because I could not set the clock to the correct date and
time, all of my SMS messages had the same incorrect date and time, the text
input did not work reliably, it used crappy Busybox instead of GNU userland
(I know I could probably replace Busybox with GNU userland, but doing so
requires a usable ssh connection.), and I could not even get a usable ssh
connection to SHR-U because I could not get bridging nor routing working on
Ubuntu and the ssh session from Cygwin on Windows Vista was very slow and
kept disconnecting.  I had the base or tiny version of SHR (I forgot what it
was called, but I can find out when I am at home tonight.), which had very
few apps, but I could not upgrade to the full version because I did not have
a usable ssh connection.), and finally QtMoko, which still has issues but is
by far the most usable distro I have tried.  I could try SHR again, but my
first impression of SHR was very poor because I do not understand how they
could release such a broken image.  If I try another distro, it has to be
able to install to and run from a MicroSD(HC) card because I need to keep my
working QtMoko installation in my onboard NAND.  I want to be able to
connect my FreeRunner directly to an Ethernet LAN instead of having to use
bridging and/or routing on a PC.  I already have a USB → Ethernet adapter,
but I am still waiting for my DealExtreme orders to arrive (it is taking
weeks. :/) so I can use my FreeRunner as a USB Host instead of only as a USB
Device.  If I could connect my FreeRunner directly to my Ethernet LAN, then
it does not matter if I cannot get a usable ssh connection to SHR-U via USB
networking, but such a connection should still work because it works fine
with QtMoko.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20091217/9b031735/attachment.htm 

More information about the community mailing list