[shr-u] GPS not working

Daniel Willmann daniel at totalueberwachung.de
Mon Dec 21 16:36:48 CET 2009


On 12/21/2009 02:54 PM, Michele Brocco wrote:
> since i installed the latest SHR-U GPS seem to not work at all. The
> SHR GUI for reading satellites shows no entry at all even after 20
> minutes outside. I think that may be related to the following problem
> with the interface naming extracted from frameworkd.log:
> 2009.12.21 11:49:13.961 ogpsd                WARNING  (could not write
> to '/sys/bus/platform/devices/neo1973-pm-gps.0/pwron': [Errno 2] No
> such file or directory:
> '/sys/bus/platform/devices/neo1973-pm-gps.0/pwron')
> but the file is called power_on here. Am I the only one experiencing
> this (I know somebody having shr-u without that problem)? Is this
> really the reason why I dont get a single entry in the satellite list
> of the shr phoneui?

This is "normal". Earlier kernel had pwron as node to control power to
GPS and since the change ogpsd just writes to both (and will always
complain about one not being there).
If you install zhone (which should be possible on SHR) you can open the
GPS tab and look at GPS in more detail. The chip will tell you which SVs
it is currently looking for and if it is receiving data or not well
before they appear in the SHR GUI.

Daniel Willmann

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : http://lists.openmoko.org/pipermail/community/attachments/20091221/67cf5e57/attachment.pgp 

More information about the community mailing list