Accelerometers in Kernel 2.6.28-rc4

Andy Green andy at
Wed Feb 4 14:39:58 CET 2009

Hash: SHA1

Somebody in the thread at some point said:
|> I'm just adding some patches and doing some cleaning on it, I'll update
|> the moredrivers kernels at when I
|> checked we didn't break the threshold stuff.
| Thanks, in the moredrivers kernel the accs are working now. But now I
have the
| following problems.
| When I use Qi it says it is not able to set some permissions and then
hangs in
| Angstroem login screen and I can not SSH into it. I also tried this
from the
| mailing list:
| "Just create a textfile "/boot/append-GTA02" and put whatever is needed as
| kernel parameters in there - here is mine:
| rw rootdelay=3 glamo_core.slow_memory=1"

Make sure you have the "rw" in there, and the /boot/append-GTA02 is in
the partition with the rootfs.  Try adding a space before the rw in case
I mangled it with recent changes.

It's a bug I think if the rootfs does not remount root rw.

| When I use U-boot I have to change the boot environment because it's
| than 2 MB. I do that the following way:
| setenv bootargs ${bootargs_base} ${mtdparts}; nand read.e 0x32000000
| bootm 0x32000000
| Then I would normally save the environment with saveenv but the system
| immediately after the setenv command. So how can I save it?

You need to escape the ; with backslashes.  Your setenv is only setting
the text as far as the first ; as it stands, then taking the nand and
bootm as new commands and running them right away.

| Then it boots sucessfully but I can not ssh into the freerunner with
| ssh: connect to host port 22: No route to host

What does

ifconfig -a
route -n

say?  dmesg on the PC side?

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the community mailing list