[debian] No right click with tslib 0.0.5-1+fso1

arne anka openmoko at ginguppin.de
Tue Feb 10 10:04:45 CET 2009

>> tslib works with Xglamo only.
>> with a regular installation you are using fb -- use libgtkstylus. i  
>> don't
>> have the exact name handy right now, but the archives should turn up
>> several hits.
> The wiki says it's the other way round. Anyway I tried both and they  
> didn't
> work...

my bad. i once built xglamo with tslib support and it worked, but for  
several reasons i abandoned that month ago and use now fbdev+libgtkstylus.

> http://wiki.openmoko.org/wiki/Debian#Simulating_right_click_with_stylus
> Is there a way to find out *why* it's not working? Atm I just try and  
> fail, this is not too productive... :D

what springs to mind are two things:
- lxde has problems itself or does not support right click (configuration  
- you configuration for tslib or libgtkstylus is wrong or interfers with  

~/.xsession-errors and/or /var/log/Xorg.0.log may contain useful  

now i have the fr handy, my working xorg.conf below (and, indeed, it is  

# Xorg confiugration for an Openmoko FreeRunner
Section "InputDevice"
         Identifier      "Configured Touchscreen"
         Driver          "tslib"
         Option          "CorePointer"           "true"
         Option          "SendCoreEvents"        "true"
         Option          "TslibDevice"           "/dev/input/event1"
         Option          "Protocol"              "Auto"
         Option          "Width"                 "480"
         Option          "Height"                "640"
         Option          "EmulateRightButton"    "1"

Section "Device"
         Identifier      "Configured Video Device"
         Driver          "fbdev"

More information about the community mailing list