[FSO M5] Paroli-Apps crash with 'Screen' object has no attribute 'etk_obj

Arigead captain.deadly at gmail.com
Tue Feb 10 15:39:11 CET 2009

Hash: SHA1

Guillaume Chereau wrote:
> On Tue, 2009-02-10 at 08:08 +0000, Arigead wrote:
>> As for Tele it does no start up the GSM modem at all, and register to
>> the network, so I can't make a call with it. Is this a know issue? I'd
>> like to help out by doing a bit of testing and giving some feedback.
>> I've probably a lot of opinion but for a start I'd like to be able to
>> make a phone call if I can't do that I'll have to reinstall zhone, but
>> I
>> was hoping to move on from that app.
> Hi John,
> They are two things you could look for :
> First, if you start paroli directy from its source directory, and you
> don't have it installed, it will read the local config file
> ./paroli.cfg, wich set GSM service to TEST, so that you will never get
> connected to the network. If you see this line the log :
>  INFO     set service GSM to Test
> Then it means you have to comment the line
>  defaults = GSM:Test, SIM:Test, Audio:Test,
> in paroli.cfg
> Second thing is that even when you run paroli using the correct GSM
> service, you get no visual indication of the connection status. And it
> can be quite long before you get a network connection.
> Could you please repeat the operation and send the log (/tmp/paroli.log)
> to the mailing list ?
> Regards,
> Guillaume

Sorry Guillaume,
    I seem to be going backwards here. I've gone through a fresh install
using the following steps from flashing a fresh rootfs into the FR

sudo dfu-util -a rootfs -R -D

now on the FR:

opkg update
opkg install python-ecore python-evas python-etk python-edje python-edbus

cd paroli/paroli-applications
sh build.sh

cd ../paroli-scripts/
DISPLAY=:0; python paroli-launcher

results in the following:

[Etk-Warning] (ecore_evas_x11.c:190 - _engine_init()):
Ecore_X initialization failed!

[Etk-Warning] (etk_engine.c:221 - etk_engine_load()):
Etk can not initialize the requested engine!

Segmentation fault

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the community mailing list