[debian] No right click with tslib 0.0.5-1+fso1

Marcel tanuva at googlemail.com
Tue Feb 10 16:27:19 CET 2009

Am Tuesday 10 February 2009 10:04:45 schrieb arne anka:
> >> tslib works with Xglamo only.
> >> with a regular installation you are using fb -- use libgtkstylus. i
> >> don't
> >> have the exact name handy right now, but the archives should turn up
> >> several hits.
> >
> > The wiki says it's the other way round. Anyway I tried both and they
> > didn't
> > work...
> my bad. i once built xglamo with tslib support and it worked, but for
> several reasons i abandoned that month ago and use now fbdev+libgtkstylus.
> > http://wiki.openmoko.org/wiki/Debian#Simulating_right_click_with_stylus
> >
> > Is there a way to find out *why* it's not working? Atm I just try and
> > fail, this is not too productive... :D
> what springs to mind are two things:
> - lxde has problems itself or does not support right click (configuration
> issue?)
> - you configuration for tslib or libgtkstylus is wrong or interfers with
> something
> ~/.xsession-errors and/or /var/log/Xorg.0.log may contain useful
> information.
> now i have the fr handy, my working xorg.conf below (and, indeed, it is
> fbdev+tslib)

Mine looks similar.
First you said "... and use now fbdev+libgtkstylus" - in your last line 
it's "fbdev+tslib" again. So *what* are you using actually?
I have now removed the modified tslib version (-fso1) again because with it 
and libgtkstylus installed simultaneously, the backlight didn't come up 
anymore once clicking the screen. ATM, I have libgtkstylus installed and 
$GTK_MODULES gets set in ~/.xsession as said in the wiki.
No right click with this setup.
Switched over to tslib with patch (0.0.5-1+fso1), removed libgtkstylus, added 
option in xorg.conf, restarted x - still no right click.

Any suggestions?


More information about the community mailing list