[SHR] Miscellanious minor issues

ivvmm unachievable at gmail.com
Thu Feb 12 22:07:58 CET 2009

Margo Koppelmann wrote:
> On Thu, Jan 29, 2009 at 6:53 AM, Joel Newkirk <freerunner at newkirk.us> wrote:
>> On Wed, 28 Jan 2009 22:26:56 -0500, Joel Newkirk <freerunner at newkirk.us>
>> wrote:
>>> 8 - I use "gprson" and "gprsoff", one-liner scripts with the following
>>> contents, which can be invoked directly but less conveniently:
>>> #!/bin/sh
>>> #gprson
>>> mdbus -s org.freesmartphone.ogpsd /org/freesmartphone/GSM/Device
>>> org.freesmartphone.GSM.PDP.ActivateContext internet3.voicestream.com x x
>>> #!/bin/sh
>>> #gprsoff
>>> mdbus -s org.freesmartphone.ogpsd /org/freesmartphone/GSM/Device
>>> org.freesmartphone.GSM.PDP.DeactivateContext
>> D'oh!! That's "org.freesmartphone.ogsmd", not "ogpsd"...
>> j
>> --
>> Joel Newkirk
>> http://jthinks.com      (blog)
>> http://newkirk.us/om (FR stuff)
> I decided to try SHR also. I like it. There's no echo! But there are
> still some small problems, that are already mentioned in the other SHR
> thread. And a few problems that aren't mentioned:
> 1. If I activate the silent profile, the phone still rings.
> 2. After using the phone few hours and making some calls the phone
> doesn't ring anymore, it only vibrates. After rebooting it rings
> again.
> 3. At some point, the phonelog application just stopped working. It
> doesn't start. I didn't do anything and I didn't change anything, I
> just made a few phonecalls. When starting it, it gives me an error
> saying, that there's no error message. When starting it from command
> line, it says:
> TypeError: float() argument must be a string or a number
> I thought rebooting wil fix this, but it didn't.
> I tried to use gprs using Joel's instructions, but it gives me the error:
> ActivateContext failed: org.freesmartphone.GSM.MUX.NoChannel

Have you solved this? Or anybody else?

Posted a request in OpenMoko community list, but no answer. Seems like
nobody notices gprs not working in shr-testing or everybody has it
working or nobody uses gprs on shr-testing.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 835 bytes
Desc: OpenPGP digital signature
Url : http://lists.openmoko.org/pipermail/community/attachments/20090213/ad37148f/attachment.pgp 

More information about the community mailing list