[2008.x] Locale packages depend on virtual-locale packages that don't exist in any language

Denis Shulyaka shulyaka at gmail.com
Mon Feb 16 11:48:09 CET 2009

I've got a kind of work around. I've created a locale with localedef
and installed *-locale-?? packages with -force-depends. Works for me.

2009/2/16, Risto H. Kurppa <risto at kurppa.fi>:
> I've been trying to install finnish localization files on my 2008.12.
> The best I've been able to do is
> echo "LANG=fi_FI.UTF-8">>/etc/profile
> echo "LC_ALL=fi_FI.UTF-8">>/etc/profile
> echo "export LANG LC_ALL">>/etc/profile
> opkg install `opkg list | grep locale-fi | cut -d' ' -f1` (thaks lindi :)
> In the end I see a long list of packages that depend on
> virtual-locale-fi that isn't available and doesn't exist anywhere. I
> suppose others have the same problem, I wasn't able to find any
> virtual-locale-file anywhere.
> What needs to be done to create this virtual-locale for each language
> so that installing it would install you all the required language
> files. Now we have tens or hundreds of packages in the repository that
> won't install without --force-depends. Is there anyone around with the
> skills to fix this? Our distro manager?
> This would make it easier to translate/use the Freerunner in your
> native language, like any other cell phone.
> r
> --
> | risto h. kurppa
> | risto at kurppa dot fi
> | http://risto.kurppa.fi
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list