[Om2008.12] Mokoko ... libid3tag0

Wirfeon jvotroubek at seznam.cz
Tue Feb 17 17:03:09 CET 2009

I have the same error with plugins but on openmoko-mediaplayer2. I tried to
install the gst-plugin-mad and libmad0 according to maryhit but i am still
getting the error.

root at om-gta02:~# opkg list_installed | grep mad
gst-plugin-mad - 0.10.7-r1.1 - 
libmad0 - 0.15.1b-r4.1 -

This is what mediaplayer says:
** Message: don't know how to handle audio/mpeg, mpegversion=(int)1,
gstreamer error: You do not have a decoder installed to handle this file.
You might need to install the necessary plugins.
gstreamer error: Internal data flow error.

maryhit wrote:
> I succeeded to play mp3 on openmoko Om2008.12 (with
> openmoko-mediaplayer2).
> You do not need Mokoko. That one is just an interface. The real issue is
> in the plugins.
> Install with with -force-depends the following files from SHR
> distribution:
> http://build.shr-project.org/shr-testing/ipk/armv4t/gst-plugin-mad_0.10.7-r1.1_armv4t.ipk
> http://build.shr-project.org/shr-testing/ipk/armv4t/libmad0_0.15.1b-r4.1_armv4t.ipk
> DO NOT install the updated version of libxml2 !!! You will get
> Segmentation Fault otherwise (the same err in mediaplayer and in mokoko).

View this message in context: http://n2.nabble.com/-Om2008.12--Mokoko-...-libid3tag0-tp2171492p2341595.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list