[Debian]Voice recorder - ecasound --> Help

kimaidou kimaidou at gmail.com
Thu Feb 19 12:21:38 CET 2009

Come back here to give some feedback :
1/ to restore one state file, you must specify the complete adress e.g.
alsactl -f /usr/share/openmoko/scenarios/gsmhandset.state restore

2/ I tried once to record via arecord and it worked (no sound because I have
not done the 1/  ). Then I killed it by CTRL+Z
But now I cannot reuse it, the command
arecord -D hw -f cd  -v -t wav ~/rec-$(date +%Y-%m-%d-%H-%M).wav
give the following error :
arecord: main:564: audio open error: Device or resource busy

How can I "de-busy" the audio device ?

Thanks in advance


2009/2/19 kimaidou <kimaidou at gmail.com>

> Hi both
> Thanks for you replies. I dumly forgot to search for "voice recording"
> among the wiki :(
> Before I try it, could you please tell if the following order and commands
> are ok (don't want to "break" my kernel**
> cd /usr/share/openmoko/scenarios/
> wget http://wildsau.enemy.org/~moko/voice-recording.state<http://wildsau.enemy.org/%7Emoko/voice-recording.state>
> arecord -D hw -f cd  -v -t wav ~/rec-$(date +%Y-%m-%d-%H-%M).wav
> alsactl -f voice-recording.state restore
>       **** HERE I TALK OR SING A SONG : La la laa laa laaaa, then ****
> killall -TERM arecord
> alsactl -f gsmhandset.state restore
> Is this correct ?
> Kimaidou
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20090219/9a89d970/attachment.htm 

More information about the community mailing list