[QtExtended] Report on 4.4.3 src on FSO

Tomas Riveros Schober triveros at enable.cl
Sun Feb 22 06:55:42 CET 2009

Hello list!
as some might have noticed, I've been struggling with my efforts to 
build QtExtended on FSO as specified on mwester's page[1]. Today I've 
been successful on building the whole pack of stuff and run it on my 
neo. So here's my report to whoever is interested (skip down to just 
check out what works and what doesn't):

Built on Ubuntu 8.04, using backported Qt.

First thing I built was FSO, but since fso-testing was not compiling 
(some packages were missing from the src repos), i decided to compile 
fso-m5. All was good (takes a long time!!).
So i built the images, then built the nox version and then the 
toolchain. All was good.
To build QtExtended was another story. No matter what I did, it would 
always complain about not finding libdbus-1 when using FSO's toolchain. 
I tried all the pkg-config wizardry I could come up with but nothing 
worked in the end, so I ended up compiling QtE using nokia's toolchain.
If anyone got any tips on how to compile QtE using FSO's toolchain, I'd 
love to know them.
So after everything was built I flashed the whole pack into the phone 
and installed QtE as mwester's instructions (thanks!), only to realize 
that 2.6.28 is terribly supported under QtE, and would kill the screen 
upon resume from suspend, and also, most thing would freeze up and just 
die a painful death.

Then I flashed a 2.6.24 kernel from openmoko's daily build[2], together 
with the modules and console image, then installed QtE again and bam! 
all was working. This is what I've tested so far:

working good:
suspend and resume
power management changes (which didn't work properly on 4.4.2)
UI speed (way better than 4.4.2)
boot speed (boots in under a minute in my phone)
GSM (it unregistered once, maybe a one-time issue), but phone quality is 
superb, and it never happened again.

not working so good:
Wifi (can register, but won't update /etc/resolv.conf so no dns, and it 
will stop working after a suspend, to never come back)

did not test yet:
GPRS (however, it was working perfectly in 4.4.2 so I assume this is 
still the case)
Bluetooth (same as gprs, was fine before)

so, if anyone was thinking about compiling 4.4.3 snapshots to get better 
networking...well, I cannot say I reccomend it since it did not fix the 
dns issues that 4.4.2 has, but it is indeed way speedier.
If anyone wants to try it, I can upload the whole set of images 
somewhere, or maybe a full backup of my phone so people can try it for 
themselves (just please notice that this is highly experimental and 
probably not very well built)

hope I didn't bore you with this lengthy post.


More information about the community mailing list