[FSO] Any luck with bluetooth headsets?

Carl Lobo carllobo at gmail.com
Sun Feb 22 12:53:10 CET 2009

I'm really not too sure about this either, but I did manage to find a
few manuals on the wolfson site and read up on the sound systems on
the wiki, but from what I've been able to understand we need to setup
the control connection using the regular bluez stack and bluez+alsa
should be sending the sound directly through to the DAI connected to
the bluetooth device (I think that's the voice ADC). From what I
gather getting BT working on a phone call should be easier using this
Using SCORouting=HCI is what you would do on a standard laptop to get
the headset working. After setting up using ~/.asoundrc using
bluetooth as the name for the headset config I can use the headset on
my laptop with something like
arecord -D bluetooth -f S16_LE | aplay -D bluetooth -f S16_LE
works - as in I could hear my own voice through the earplug of the
bluetooth headset (I had tried this a long while back with bluez
3.3[63] I think). The same thing did not work on the FR.
With SCORouting=PCM I did get static and some sought of noise once the
control connection was established...

mdbus -s org.bluez

lists a device - the path should be something like
/org/bluez/<pid>/hci0/dev_<some mangled form of the btaddr> for my
headset (it's paired and trusted).

After that

mdbus -s org.bluez /org/bluez/1387/hci0/dev_00_21_3C_07_5E_8E

Connects me to the headset

mdbus -s org.bluez /org/bluez/1743/hci0/dev_00_21_3C_07_5E_8E

Tells me (from the bluetoothd log) that the headset is playing.

I tried playing a 8kHz 16 bit mono track and if I select DAI 0,2,3 it
plays through the speakers. But if I select DAI 1 aplay simply hangs
and even Control-C can't kill it.

On a phone call if I try to restore from either of the state files on
the wiki or play around with alsamixer I get no sound at all, either
from the phone/FR or headset.

More information about the community mailing list