[FSO] Any luck with bluetooth headsets?

Simon Kagstrom simon.kagstrom at gmail.com
Sun Feb 22 14:32:41 CET 2009

On Sun, 22 Feb 2009 17:23:10 +0530
Carl Lobo <carllobo at gmail.com> wrote:

> Using SCORouting=HCI is what you would do on a standard laptop to get
> the headset working. After setting up using ~/.asoundrc using
> bluetooth as the name for the headset config I can use the headset on
> my laptop with something like
> arecord -D bluetooth -f S16_LE | aplay -D bluetooth -f S16_LE
> works - as in I could hear my own voice through the earplug of the
> bluetooth headset (I had tried this a long while back with bluez
> 3.3[63] I think). The same thing did not work on the FR.

I tried this now as well, but it fails with

  ALSA lib pcm_bluetooth.c:1593:(bluetooth_init) BT_GETCAPABILITIES failed : Unknown error 240(240)
  aplay: main:546: audio open error: Unknown error 240
  Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 8000 Hz, Mono
  Warning: rate is not accurate (requested = 8000Hz, got = 16000Hz)
         please, try the plug plugin (-Dplug:bluetooth)

(although I hear that the headset does something). It also fails with
-Dplug:bluetooth. However, this way, I'm able to play back oggs with
mplayer (choppy), so it's doing something right at least.

> After that
> mdbus -s org.bluez /org/bluez/1387/hci0/dev_00_21_3C_07_5E_8E
> org.bluez.Headset.Connect

I didn't get this working though, I get

   Connect failed: org.freedesktop.DBus.Error.UnknownMethod

when trying various combinations of paths there.

// Simon

More information about the community mailing list