Need help flashing my freerunner for the first time

Adam Jimerson vendion at
Tue Feb 24 02:11:54 CET 2009

On Mon, Feb 23, 2009 at 7:41 PM, <roguemoko at> wrote:

> Adam Jimerson wrote:
> > I got it to show up and I started to back it up but the phone shut off
> > for being in NOR boot for about 30 minutes, the Freerunner is the only
> > USB device connected to my computer and I did try other ports before
> > getting it to work.
> I think this can be distro related as I've never had issues, even with
> many devices connected to usb. I use archlinux.
> When you say 'backup', if you mean you were backing up the existing
> flash then I wouldn't bother, especially if it's not working properly
> anyway.
> Flashing the FR should only take ~10min. The u-boot timeout only applies
> when idle, so make sure your battery is well charged.
> When I have had issues, it has related to the usb cable, so maybe try
> another. Also, it may be worth identifying the ID of the FR and
> submitting it to dfu-util.
> Outside of that, maybe try a different version of dfu-util.
> Good luck.
> Sarton
> _______________________________________________
> Openmoko community mailing list
> community at

It was mostly the version of dfu-util that I was using, I installed it from
my distro's repo and there was a new version packaged after I installed it.
After upgrading that it seems I just need to wait a couple of seconds after
connecting the usb cable before running dfu-util, by doing that it works on
ether the first or second try.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list