Flashing GSM firmware

Paul Fertser fercerpav at gmail.com
Tue Feb 24 11:01:12 CET 2009

"Steve \" 'dillo\" Okay" <armadilo at roadknightlabs.com> writes:
> Okay, I am pretty stuck here.
> I've tried the procedure on the  Wiki here:
> http://wiki.openmoko.org/wiki/GSM/Flashing
> and here:
> http://lists.openmoko.org/nabble.html#nabble-td1565196|a1566012
> to no effect.
> I run the fluid command and it just sits there at:
> Bootloader: (reset target)
> In the other terminal window, I'm repeatedly doing
> echo 0 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
> echo 1 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
> to no effect.

I estimate the probability of this not working for the first time as
0.1. So, after the second try it will most certainly work. Are you
sure nothing is accessing your modem at that time? Use lsof to
check. Also, it's possible that your kernel version has power_on sysfs
node in another place, make sure the node actually exists there.

Be free, use free (http://www.gnu.org/philosophy/free-sw.html) software!
mailto:fercerpav at gmail.com

More information about the community mailing list