Flashing GSM firmware

Steve " 'dillo" Okay armadilo at roadknightlabs.com
Tue Feb 24 14:07:54 CET 2009

On Feb 24, 2009, at 11:01 , Paul Fertser wrote:

> "Steve \" 'dillo\" Okay" <armadilo at roadknightlabs.com> writes:
>> Okay, I am pretty stuck here.
>> I've tried the procedure on the  Wiki here:
>> http://wiki.openmoko.org/wiki/GSM/Flashing
>> and here:
>> http://lists.openmoko.org/nabble.html#nabble-td1565196|a1566012
>> to no effect.
>> I run the fluid command and it just sits there at:
>> Bootloader: (reset target)
>> In the other terminal window, I'm repeatedly doing
>> echo 0 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
>> echo 1 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
>> to no effect.
> I estimate the probability of this not working for the first time as
> 0.1. So, after the second try it will most certainly work. Are you
> sure nothing is accessing your modem at that time? Use lsof to
> check. Also, it's possible that your kernel version has power_on sysfs
> node in another place, make sure the node actually exists there.

I'm using the fso-console image recommended in the GSM Flashing wiki  
downloaded from here:

The /sys/bus/platform entry is a symbolic link to /sys/devices/ 
platform and contains:
root at om-gta02:/sys/devices/platform/neo1973-pm-gsm.0# pwd
root at om-gta02:/sys/devices/platform/neo1973-pm-gsm.0# ls -l
-rw-r--r--    1 root     root         4096 Feb 24 11:05 download
lrwxrwxrwx    1 root     root            0 Feb 24 11:05 driver - 
 > ../../../bus/platform/drivers/neo1973-pm-gsm
-rw-r--r--    1 root     root         4096 Feb 24 11:05 flowcontrolled
-r--r--r--    1 root     root         4096 Feb 24 11:05 modalias
drwxr-xr-x    2 root     root            0 Feb 24 11:05 power
-rw-r--r--    1 root     root         4096 Feb 24 11:05 power_on
-rw-r--r--    1 root     root         4096 Feb 24 11:05 reset
lrwxrwxrwx    1 root     root            0 Feb 24 11:05 subsystem - 
 > ../../../bus/platform
-rw-r--r--    1 root     root         4096 Feb 24 11:04 uevent
root at om-gta02:/sys/devices/platform/neo1973-pm-gsm.0#

So it looks like the power_on node is there. The default value at  
boot of the power_on node is 0.

  I'll try writing to it directly rather than going through the link,  
although I don't know why that would make any difference.
lsof reveals nothing interesting.
I ran the gsm0710muxd start script and it shows that the gsm daemon  
isn't running:
root at om-gta02:/# /etc/init.d/gsm0710muxd stop
no process in pidfile '/var/run/gsm0710muxd.pid' found; none killed
root at om-gta02:/#

What you're saying makes sense, i.e. that something is using the GSM  
modem, but it does look it's shut off.

Thanks for your help,

More information about the community mailing list