[SHR unstable] bluez-utils bluez4

Jakob jackramone at googlemail.com
Tue Feb 24 22:11:20 CET 2009

On Tue, Feb 24, 2009 at 2:33 PM, Valerio Valerio <vdv100 at gmail.com> wrote:
> On Tue, Feb 24, 2009 at 1:47 AM, Carl Lobo <carllobo at gmail.com> wrote:
>>> bluez4 provides the 4.x branch of bluez rather than the 3.x branch. It should
>>> provide the same functionality, but some bits may work differently. You could
>>> try to install without dependencies to see if remoko will work with bluez4.
>> I tried remoko with bluez4 and it keeps saying "Waiting for connection
>> from server" or something indefinitely.. :(.
>>bluez4 has a different
>> DBus API, maybe it requires some porting?
> Yup, the DBus API and other things are different in Bluez4, try to run
> ReMoko through ssh or in a console and paste the output here.
> Best regards,
> --
> Valério Valério
> http://www.valeriovalerio.org

When i run remoko with bluez4 installed it says this:
root at neo ~ $ DISPLAY=:0 remoko
warning: x11-16 is not supported, fallback to x11
DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)
could not create proxy for
org.freedesktop.DBus.Error.ServiceUnknown: The name
org.openmoko.accelges was not provided by any .service files
error in proxy
failcount= 0
usage ok <Interface <ProxyObject wrapping <dbus._dbus.SystemBus
(system) at 0x29ef90> :1.10 /org/freesmartphone/Usage at 0x29f9d0>
implementing 'org.freesmartphone.Usage' at 0x29fc10>
failcount= 0
Traceback (most recent call last):
  File "/usr/share/remoko/remoko/remoko", line 2103, in <module>
    gui = GUI( options, args )
  File "/usr/share/remoko/remoko/remoko", line 1537, in __init__
  File "/usr/share/remoko/remoko/remoko", line 1609, in initialize_remoko_server
    self.connection = Connect()
  File "/usr/share/remoko/remoko/remoko_server.py", line 43, in __init__
    self.input = dbus.Interface(bus_input.get_object('org.bluez',
'/org/bluez/service_input'), 'org.bluez.Service')
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line
622, in call_blocking
    message, timeout)
org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not
provided by any .service files



More information about the community mailing list