[SHR/FSO] - GPS - no fix, ogpsd.pickle question

Leonti Bielski prishelec at gmail.com
Wed Feb 25 15:58:17 CET 2009

I'm running latest SHR unstable distribution and there is no way I can
get gps fix.

1. System time and timezone are set correctly.
2. ogps.pickle removed.
3. Phone restarted.
Still no fix.

I even tried to reflash phone to om 2008.08 distro - "Locations"
application can get my GPS position.
When I'm back to SHR - no fix.

I'm checking for fix with Zhone to 'cut the middle-man' and be sure
it's gps, not fso-gpsd or any other problem.
So shortly after I launch Zhone and press 'gps' button I see in terminal:

Requested debug packet NAV-SVINFO
gps fix status changed: 1 #it can't be real fix, because it happens in
a few seconds

gps got ubxdebug packet
gps got ubxdebug packet # to infinity and beyond

Please notice, that this test was made in the same exact location with
an external antenna at approximately same time with om 2008.8 distro
and SHR unstable with (2.6.28 kernel).
I know a lot of people have problems with GPS in SHR Unstable, so it
would be beneficial for all of us to find the problem.

Can someone point me to low-level stuff I should check to get to the
bottom of this?


More information about the community mailing list