[SHR-unstable] wrong timezone setting

William Kenworthy billk at iinet.net.au
Sat Feb 28 11:43:00 CET 2009

I think its otimed thats doing it - tried to set my timezone over 3000
km from where I am, and tried to sync time with somewhere in Germany (I
am in Australia)

There is a way to turn this off with a couple of lines
in /etc/frameworkd.conf - search the wiki for that file and it should
explain the relevant lines.

I really should raise a bug about otimed as its a really bad piece of
design in a number of areas (using a fixed IP, using gsm to set time,
one shot time setting, ...) but I dont have a lot of confidence in
raising a bug for issues like this - it'll just get ignored.


On Sat, 2009-02-28 at 12:47 +0300, ivvmm wrote:
> Within a month getting problems with setting localtime. As far as I can
> see there is a wrapper in /etc/timezone, where a timezone should be
> written. Put there 'Europe/Moscow'(without quotes) and u have to restart
>  to make changes to it.
> It seems that symlinking /usr/share/zoneinfo/whateverzone to
> /etc/localtime is dangerous as the FSO wrapper edits the file
> /etc/localtime. So instead of restarting the phone u may just copy
> /usr/share/zoneinfo/Europe/Moscow to /etc/localtime and check with
> $(date) command that shows that tz has correctly changed to MSD.
> But if u restart, soon after entering the PIN the timezone will fall
> back to EET.
> It always falls back to EET.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community
William Kenworthy <billk at iinet.net.au>
Home in Perth!

More information about the community mailing list