[debian] navit: rendering is slow

Joachim Breitner nomeata at debian.org
Fri Jan 2 23:51:08 CET 2009


Am Freitag, den 02.01.2009, 18:50 +0100 schrieb arne anka:
> >>> --enable-avoid-float
> > I think the first parameter to avoid floating point operations should
> > help quite a bit on such a low performance system which has to do fp
> > with integer commands.
> if it is indeed the one kazer had in mind. maybe it should be rather  
> configurable by config instead of hardcoding?
> and anyway it would be nice if configure could manage to enable those  
> fixes automatically depending on the target arch ...

actually, not by config but by looking at the hardware it runs on :-)

I don’t think it’d be inefficient if this check happens once at startup.
It’d increase the binary size, but that’d be ok for a general purpose
distro such as Debian.

But I see navit isn’t in the official Debian repositories yet, otherwise
I’d suggest you file a wishlist bug report. It would also be possible,
as an easiy solution, to set this flag depending on the architecture the
package is built for.


Joachim "nomeata" Breitner
Debian Developer
  nomeata at debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata at joachim-breitner.de | http://people.debian.org/~nomeata
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://lists.openmoko.org/pipermail/community/attachments/20090102/8136e71f/attachment.pgp 

More information about the community mailing list