[debian] navit: rendering is slow

Petr Vanek vanous at penguin.cz
Sun Jan 4 14:35:53 CET 2009

>Now i see what you meant in navit (1885).
>Only in the gui "internal" the setting 3D exist, not in the gui "gtk".
>Now when i click on 3D and change back to the map it is showm in 3D

yes, i use gui internal

>But the problem is that the map is veeeeeeeery slow in 3D mode. I tried
>it on my pc first and it needed ~5s to drag the map from A to B. I
>think the problem is that in 3D mode navit still shows all items on
>the map which results in overfilling at the horizon. I attached a
>screenshot from my pc which shows the problem.

for some reason, i am not sure that it is that slow on my fr, but i
couldn't really use it either as the cursor is wrong way and therefore
the maps shows what's behind my car rather then in front of it :)

i think this is broken now in the 2D view as well...

>I played a bit with the tilt="..." parameter in navit.xml which should
>adjust the tilt of the 3D view but it seems to have no effect. Also i
>can't find any parameter to adjust the viewdistance for items on the
>map or the map itself which should increase the speed a great bit.

i haven't had time to try to tweak those settings

>What settings do you use that it is acceptable fast when you are using
>the 3D view on your freerunner?

actually, my navit.org was attached to my email 29 Dec 2008 22:09:40
just i bit up in this thread. no special settings, i only got
uncommented settings for more on screen display items.


More information about the community mailing list