Debug Board in Vancouver, BC

Vasili Sviridov vsviridov at
Mon Jan 5 02:35:43 CET 2009

Wow, that's detailed :D Thanks, I will try this right away...


Mike Montour wrote:
> Vasili Sviridov wrote:
>> Hello All,
>> Since both my previous posts haven't helped me to fix my phone looks 
>> like I need to devirginate it. Unfortunately I do not have the debug 
>> board, and paying $100 + shipping is a bit steep for just one thing to do.
>> Is there anyone in Vancouver, BC that has one and willing to help me to 
>> get my Moko working - please respond.
> I have a v2 (Neo1973) debug board in Vancouver, but you shouldn't need 
> it if you have a Freerunner with a working NOR u-boot.
> I haven't read all of the previous messages in this thread so someone 
> else might have already said this, but I would:
>   - Boot into NOR u-boot
>   - Erase the NAND ("nand erase" or "nand createbbt")
>   - Exit from the u-boot console
>   - Flash a new u-boot ("dfu-util -R -a u-boot -D /path/to/u-boot.bin")
>   - Reboot into NAND u-boot, then enter the u-boot console
>   - Execute "dynpart", "dynenv set u-boot_env", "saveenv" to set up the 
> default environment variables
>   - Reboot into NAND u-boot again
>   - Download a new kernel + rootfs with dfu-util
>   - Fix up the rest of your environment variables through the u-boot 
> console.
> _______________________________________________
> Openmoko community mailing list
> community at

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list