When will kernel 2.6.24 be replaced by andy 2.6.28 kernel for better suspend/resume?

Paul Fertser fercerpav at gmail.com
Tue Jan 6 14:46:39 CET 2009


Fox Mulder <Quakeman1 at gmx.net> writes:
>> Actually, you can try to change from 2.6.24 after applying an ad-hoc
>> patch from http://trac.freesmartphone.org/ticket/293 even on old
>> version that's provided by Debian (that's exactly what i did a month ago).
> Ok.
> I downloaded the fso-frameworkd source, copied the patch into it and
> applied it without any problems. Now do i install the fso-frameworkd
> with "./setup.py install" ?

That's distribution-dependent. I'd suggest to apply the patch to the
frameworkd you have already installed and change
/etc/freesmartphone/oevents/rules.yaml by hand.

Or if you want to try to install from source, you probably don't need
any patches at all, as you can install a version recent enough (though
it's possible that some SHR apps are not ready yet).

> But i have the problem that on [1] only the 2.6.28 kernel but no modules
> are online. Where do i get the corresponsing modules for this kernel?
> Last time i checked there was an older kernel with a modules package but
> no more.

I think it's assumed that everything you need for everyday work is
compiled-in. If you want to use some webcams or other unusual devices,
just compile a kernel yourself from git, it's not hard. Or ask Andy to
provide all the modules ;)

Be free, use free (http://www.gnu.org/philosophy/free-sw.html) software!
mailto:fercerpav at gmail.com

More information about the community mailing list