python-elementary missing (also concerning

morphis morphis at
Sat Jan 10 13:30:29 CET 2009

On 10.01.2009 11:02, Risto H. Kurppa wrote:
> Hi!
> I tried to install osmupdater from (
> Trying to run it, I get:
> Traceback (most recent call last):
> File "/usr/bin/", line 2, in
> import elementary, os,time, sys
> ImportError: No module named elementary
> ok, so python-elementary is missing.
> I tried to look for it in the repositories and this is the only place
> I was able to find it:
> - in the SHR
> repositories..
> so:
> 1) Why is it missing from the openmoko repositories? It looks like
> that it's been there before (for example this tries to install it from
> the repositories: so I take it's
> worked at some stage..)
> 2) is it safe to install the SHR python-elementary
> 3) is it OK to upload programs to that require packages like
> this that are not easily available?
> Thanks!

python-elementary is currently available through normal openembedded. If 
you are on a distribution made by openmoko, you currently will not have 
python-elementary, because actually they don´t merge there branch with 
the master branch of openembedded.
I think is missing a flag to show for which distribution the 
package was made. Only pointing on the dependency on 
isn't a solution.

More information about the community mailing list