Problem in fso-frameworkd

Michele Renda michele.renda at
Sun Jan 11 18:33:21 CET 2009


I have a question about FSO framework. I think there is something 
strange. I would like to know if is good to open a bug report.

I use Debian at FR updatet until today, with fso-frameworkd_0.8.4.3-20081215

Let suppose I am starting with a just started system:

To be able to use the GSM subsystem I have to enable GSM: how to do it?

1)  mdbus -s org.freesmartphone.frameworkd 
/org/freesmartphone/GSM/Device Enable

FIRST PROBLEM: If I call 2 times this, the frameworkd stop to run... or 
better, if I try to make another GSM call (for example:  "mdbus -s 
org.freesmartphone.frameworkd /org/freesmartphone/GSM/Device GetStatus" 
the answer is org.freedesktop.DBus.Error.NoReply
  I think it would be better to have the possibility to call n times the 
Enable function.

SECOND PROBLEM: How I can check is a section is enabled? It woulrd be 
nice to have a function like:
mdbus -s org.freesmartphone.frameworkd /org/freesmartphone/GSM/Device 
GetAbilitation GSM to know if it is enabled or not.

THIRD PROBLEM: I thought that I have to use the functions shown with:
mdbus -s org.freesmartphone.frameworkd /org/freesmartphone/Usage

The problem is that if I call:
mdbus -s org.freesmartphone.frameworkd /org/freesmartphone/Usage  
RequestResource GSM
it seem to do nothing, because if I call:
mdbus -s org.freesmartphone.frameworkd /org/freesmartphone/Usage  
GetResourceState GSM
the result is:
/org/freesmartphone/Usage: GetResourceState ->  0

Thank you all
Michele Renda

More information about the community mailing list