FSO unstable upgrade errors alsa-states and initscripts-openmoko

arne anka openmoko at ginguppin.de
Thu Jan 15 16:31:10 CET 2009

> Hi Arne, thanks for your quick reply.  Yes, initscripts-openmoko still
> exists in the unstable feed and initscripts likewise.

confusing. iw ould download both packages and look into the contents,  
inhwofar the may be identical.
who provides this feed? you should contact him/report a grave bug.

or are this two separate feeds, one providing initscripts-openmoko and the  
other plain initscripts?
in this case you better use the more official one and remove the other  
package manually.

>  As for the
> alsa-states problem, it seems I don't have an /etc/asound.state file.

could you please try to install alsa-states and post the full log? if opkg  
has some verbose parameter, set it to the highest possible value.
there should be a way to list the contents of installed packages, please,  
list both alsa-states and openmoko-alsa-scenarios and check for the file.

> I've managed to flash the
> uImage-2.6.28-oe1+gitr34240a1c06ae36180dee695aa25bbae869b2aa26-r2-om-gta02.bin
> kernel but can only run it with
> openmoko-fso-image-glibc-ipk--20090108-om-gta02.rootfs.jffs2 rootfs  
> anything later than 08/01 and I can't boot.

sorry, you lost me.
what means "<uimage> but can only run it with <image>" compared to "I  
can't boot"?

More information about the community mailing list