what tests for (non working) 3G SIM?

Sargun Dhillon xbmodder+openmoko at gmail.com
Wed Jan 28 10:36:12 CET 2009

This assumes you've turned on your modem already...
A bit more detail:
kill -9 `ls -l1d /proc/*/fd/*|grep ttySAC0|cut -f3 -d/|grep -v self`
echo 0 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
echo 1 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
#Yes, do it twice... Ignore errors you see on the GUI...
kill -9 `ls -l1d /proc/*/fd/*|grep ttySAC0|cut -f3 -d/|grep -v self`
echo 0 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
echo 1 >/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on
cat /dev/ttySAC0 &
echo -en 'AT\r' >/dev/ttySAC0
echo -en 'AT+CGMR\r' >/dev/ttySAC0
kill %1
#paste ALL of the output of this when you send an e-mail complaining
about GSM firmware issues.

On Wed, Jan 28, 2009 at 1:23 AM, Arigead <captain.deadly at gmail.com> wrote:
> Hash: SHA1
> Sargun Dhillon wrote:
>> When reporting broken 3G SIMs please give us the output of:
>> root at om-gta02:~# cat /dev/ttySAC0 &
>> root at om-gta02:~# echo -en 'AT\r' >/dev/ttySAC0
>> root at om-gta02:~# echo -en 'AT+CGMR\r' >/dev/ttySAC0
>> +CGMR: "HW: GTA, GSM: gsm_ac_gp_fd_pu_em_cph_ds_vc_cal_amd8_ts0-Moko10"
>> root at om-gta02:~# kill %1
>> -Thanks
> Sorry I should have said my phone is a bit confused and the command
> "cat /dev/ttySAC0 &"
> returns immediately as "done" so there is no output from the other echo
> commands. I'll reflash the phone and see if I can get some sense out of it.
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> QsEAoMI4RnhEDW5nHEeOGNU4drdR6Ibd
> =3MNb
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list