[Om2009] bluetooth keyboard - key presses not making it to X

Al Johnson openmoko at mazikeen.demon.co.uk
Fri Jul 3 13:52:20 CEST 2009

On Friday 03 July 2009, Tim Abell wrote:
> Hiya,
> Thanks for the suggestion. I had seen that bug but hadn't known what to
> try.
> I've now updated to shr-unstable, and have exactly the same symptoms as
> before, with  events showing in hcidump but not in xev. I've tried
> changing the startup parameters of Xglamo as suggested, I tried removing
> vt1, I tried replacing it with vt0 (x won't start like that), and vt2.
> None of these fixed the problem.
> It may be worth noting that if I stop X, then I don't get any output
> from the bluetooth keyboard appearing on the console on the phone unlike
> in the bug report you mention.
> Any other ideas?

If input isn't getting to the console either then check whether the keyboard 
is actually appearing as an input device. You could check dmesg or logread, or 
	ls -l /dev/input/by-path/
	hal-find-by-capability --capability input.keyboard

More information about the community mailing list