linphone 3.1.0

Denis Shulyaka shulyaka at
Sun Jul 5 20:26:47 CEST 2009

2009/7/2 Al Johnson <openmoko at>:
> On Thursday 02 July 2009, Denis Shulyaka wrote:
>> Hi! I'm trying to use linphone on Om2009 and can't get sound working
>> properly. Which asound.conf and voip.state file should I use? I tried
>> opnes from but all I got was ringing sound, no voice in any
>> direction. The ringing sound was from speaker, not earpiece.
> I haven't tried it on Om2009 yet. On FSO-ms5 I used the voip-handset.state
> that was already in FSO, and
> Did you remember to switch the mixer state? This needs to be done manually
> because linphone isn't FSO-aware yet. If the ring came from the speaker then
> either voip-handset.state wasn't the active state or it has changed. IIRC
> linphone has play and record options that should let you check its audio
> settings independent of any problems you may be having with SIP.
> I'm planning to give OM2009 a try soon, so I may have some more ideas soon.

Hi! I've just tested it with SHR-testing and it is still ringing from
the speaker, not earpiece. I'm sure I remembered to run "alsactl
restore -f voip-handset.state". The voip-handset.state seems good to
me. So what's it? Alsa bug or I broke something in hardware while
implementing buzz-fix?

More information about the community mailing list