[shr] i did something really stupid...help needed with opkg

Robin Paulson robin.paulson at gmail.com
Sat Jul 11 10:01:11 CEST 2009

2009/7/11 Edder <edder at tkwsping.nl>:
> I don't know opkg to well, so when I run into problem I often just end up
> editting /usr/lib/opkg/status by hand. You could try removing libc entry
> from there and then reinstalling libc. Not sure if it will help with your
> particular problem! Ofcourse I advice you to first wait if someone else can
> help who actually knows opkg.

ah, i wondered where the opkg db was:

Package: libc6
Version: 2.6.1-r16
Status: deinstall user installed
Architecture: armv4t

Package: libc6
Version: 2.7-18
Depends: libgcc1
Suggests: locales, glibc-doc
Provides: glibc-2.7-1
Conflicts: libterm-readline-gnu-perl (<< 1.15-2), tzdata (<< 2007k-1),
Status: install prefer,user not-installed
Architecture: armel

which doesn't look great. i'm not sure how it has two versions
installed. or whether deleting the second entry entirely will fix

is there anyone here who knows opkg inside out?

More information about the community mailing list