[shr] i did something really stupid...help needed with opkg

arne anka openmoko at ginguppin.de
Sat Jul 11 12:04:41 CEST 2009

> Package: libc6
> Version: 2.6.1-r16
> Status: deinstall user installed
> Architecture: armv4t
> Package: libc6
> Version: 2.7-18
> Depends: libgcc1
> Suggests: locales, glibc-doc
> Provides: glibc-2.7-1
> Conflicts: libterm-readline-gnu-perl (<< 1.15-2), tzdata (<< 2007k-1),
> tzdata-etch
> Status: install prefer,user not-installed
> Architecture: armel

judging from debian, i'd propose these steps (do it on your own risk, but  
as long as actually a libc6.so is avaliable, you probably can't really  
break anything except opkg's idea of the system):

- back up status file!
- get a listing of _all_ files belonging to the libc6 deb (including  
postinst, preinst, and so on)
- get the stanza for a correctly installed libc6 ipk (debian ha a  
staus-old, but if opkg has too, it might have been overwritten already;  
some other shr user could post it) and replace the one in your status  
file; remove the stanza for the deb
- get the libc6 ipk and install manually
- remove all files belonging to the deb
- check for consistency, probably those debs you mentioned will be broken,  
because the libc6 package version doesn't match

More information about the community mailing list