[SHR-U] Bluetooth and GSM... Again.

DJDAS djdas at djdas.net
Tue Jul 14 10:17:49 CEST 2009

Paul Fertser ha scritto:
> The Digital Pioneer <digitalpioneer at gmail.com> writes:
>> Paul said that the connection for bluetooth runs straight from one chip to the other, without really
>> involving ALSA at all. Is there a way we can make it involve ALSA, since bluetooth works perfectly
>> through ALSA?
> Bluetooth for you works perfectly only one way most probably
> (A2DP). If you want to try to use SCO over HCI (bt usb interface)
> you'll face the same issue with "everything works but no sound for
> unknown reason and even bluez devs say everything is ok judging by
> your hci dumps". :(
> Also it requires modifications to BT chip EEPROM.
> I did that myself and i had sound with "working" headset and had no
> sound with non-working (exactly the same software configuration worked
> with it just fine on my laptop where other brand of bt chip is used).
> And don't forget, A2DP - unidirectional audio, for conversations you
> need SCO.
> BTW, have you tried disabling esco or not?

Well, this is partially true (even if I can't provide a solution, yet). 
During my researches before creating BlueMoko (I think I'll put my hands 
on it to port to bluez4 and new kernels starting from August), I did 
different tests with my 2 headsets, one (Nokia) which is only a simple 
headset, and the second (Calypso) is an AD2P+Headset type.
The A2DP one works flawlessly with the A2DP profile and I use it for 
media playing, while the headset profiles (for both of them) worked some 
time and others no.
Consider I didn't change anything in my distro (kernel, packages, libs, 
etc) but there were cases of both working (to be honest the Nokia one 
worked only two times and it isn't broken as I use it with my Nokia cell 
phone in some cases) and the audio is correctly routed (I tested by 
recording a call with another phone, so I'm sure they work).
Even looking at the logs I wasn't able anymore to understand why this 
behavior but I had no time since then to do some checks, I suspect 
suspending the phone creates some strange things on the bluetooth stack 
but (again) A2DP is not affected and always works.
If you want to contribute to BlueMoko by testing the headset functions, 
you can find the sources on the projects.openmoko site and I can provide 
even the distro which I use for my tests (my daily distro), I know it's 
a bit outdated but it works ;)
P.S. I would like to be a Tom but I cannot guarantee so much time to 
develop due to my work, so please be patient :)

More information about the community mailing list