[shr-u] navit - howto config navit.xml

Petr Vanek vanous at penguin.cz
Thu Jul 16 19:24:54 CEST 2009

On Thu, 16 Jul 2009 18:45:53 +0200
Davide Scaini <dscaini at gmail.com> (DS) wrote:

>I installed navit via
>opkg install navit
>(the version i got is 0.1.0+svnrev2309-r2 )
>then i copied /usr/share/navit/navit.xml in /home/root/.navit/navit.xml
>I tried to run navit but with no luck.
>Yhen i added in the right place this lines
>    <mapset enabled="yes">
>        <map type="binfile" enabled="yes"
>    </mapset>
>but i still get
>root at om-gta02 ~ $ navit
>Enabling low-mem workaround...
>navit:vehicle_new:invalid type 'gpsd'
>navit:speech_new:wrong type 'cmdline'
>navit:map_new:invalid type 'binfile'
>navit:navit_init:no gui
>navit:main:Using '/home/root/.navit/navit.xml'
>navit:main:No instance has been created, exiting
>wtf!?? is there anyone who has an idea why?

navit might require libgps16, simply make link from libgps17 /make sure
it's installed)

More information about the community mailing list