[shr-u] navit - howto config navit.xml

Davide Scaini dscaini at gmail.com
Sat Jul 18 09:00:52 CEST 2009

on Fr now... so i'll be short.
i installed navit-dev and now it runs! i can see my actual position
but unfortunately no map under. [i have downloaded the entire Italy
from planet osm. i get no errors but no maps ... step by step i'll
thanks guys for your help

On 7/17/09, Sebastian Krzyszkowiak <seba.dos1 at gmail.com> wrote:
> On 7/17/09, Davide Scaini <dscaini at gmail.com> wrote:
>> tried all:
>> - installed shr on a big sd card
>> - installed navit first form opkg repos
>> - tried navit -> no result
>> - modified navit.xml with internal gui -> no result
>> - export NAVIT_LIBDIR=/usr/lib/ -> no result
>> - installed latest navit -> no result
>> get the very same error (???)
>> d
>> On Fri, Jul 17, 2009 at 2:38 PM, Davide Scaini <dscaini at gmail.com> wrote:
>>> @Kazer:
>>> ok, so your advice is to download the latest navit instead of the one
>>> that
>>> comes with shr-u?
>>> thanks for your detailed reply ;-)
>>> d
>>> On Fri, Jul 17, 2009 at 2:29 PM, KaZeR <kazer at altern.org> wrote:
>>>> I would recommend copying navit.xml to /home/root/.navit, because a
>>>> package
>>>> upgrade could overwrite it. And it's a good idea to diff your xml
>>>> against
>>>> the shipped one for updates from time to time.
>>>> Also, opkg's memory leak (or whatever was making it to eat 100% cpu and
>>>> memory) has been fixed (at least in SHR-unstable) so now it's again easy
>>>> to
>>>> use navit's daily builds from http://download.navit-project.org/navit/
>>>> (where the current revision is around 2395 i believe).
>>>> Davide : if navit says that no gui can be loaded, then either it cannot
>>>> find
>>>> the .so files (can be because of a wrong NAVIT_LIBDIR variable) or that
>>>> you
>>>> choosed a gui that isn't available (not built) from your navit.xml.
>>>> Recent packages of navit include a better config sample for the Neo
>>>> (internal, with better settings for icon_xs and co). I can share my
>>>> navit.xml if needed.
>>>> --
>>>> View this message in context:
>>>> http://n2.nabble.com/-shr-u--navit---howto-config-navit.xml-tp3272259p3275104.html
>>>> Sent from the Openmoko Community mailing list archive at Nabble.com.
> Did you install navit-dev? ... It provides symlinks which navit tries
> to use. You can also tweak config, but that's little more difficult.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

More information about the community mailing list